Jusqu’à la dernière heure, il n’était pas prévu de créer un nouveau thème avec WordPress 5.0, mais il a été décidé d’incorporer un thème déjà parfaitement compatible avec les nouveaux blocs d’édition de Gutenberg afin de poursuivre la tradition de WordPress d’inclure un thème adapté aux nouvelles versions.

Allan Cole, un concepteur de thème WordPress chez Automattic l’entreprise que développe et distribue WordPress a publié les premiers aperçus du thème par défaut destiné à être livré avec WordPress 5.0.

Le nouveau thème WordPress par défaut, Twenty Nineteen, a un design très minimaliste, peut-être à cause du peu de temps qu’il a été développé. Cet approche minimaliste convient parfaitement aux éditeurs et peut également être adapté à des sites commerciaux simples.

Fondamentalement, il s’agit d’un thème avec une structure pleine largeur, sans barres latérales, avec une grande zone d’en-tête et une zone de widgets dans le pied de page.

Twenty Nineteen est basé sur les thèmes de départ Underscores et Gutenberg et aura une compatibilité totale avec Gutenberg lors de sa sortie. Il contiendra également les styles d’éditeur Front-end et Back-end. Cela permettra à la présentation du contenu dans le back-end de ressembler de près à l’apparence du produit fini.

Par ailleurs, tous les thèmes par défaut précédent sont également été mis à jour pour être compatibles avec les styles des blocs de l’éditeur Gutenberg.